Won't pair with Mac app


#1

Mac app fails to pair with new Turn Touch. After scanning for remotes, error appears (‘no remotes could be found’). There don’t seem to be a lot of options for me to try as far as troubleshooting goes.


#2

I have the exact same issue. Do I need to press something to get the remote into bluetooth pairing mode?

Just to follow up, I opened up the remote to check the battery, the best I could do is touch it to my tongue to see if it had any power which it did.


#3

Ok I just pushed out a new update that should help. Upgrade (the app should do this automatically but you can force an upgrade by going to Settings > About > Check for Updates) and let me know if that helps. It may take a couple tries. Bluetooth is ridiculous but it should eventually work.


#4

Thanks for the update. Unfortunately, still a no-go for me. Updated the app, tried (and retried) to pair. Also tried toggling Bluetooth on the Mac, restarting, etc.

I have not done the tongue-on-battery test. Should I? A little reluctant to crack it open…

(Meantime, I’ll keep randomly retrying.)


#5

Ensure that the battery is charged. You might want to try with another cr2032 coin cell battery. And opening the case is harmless, no tools required. It’s held together with magnets.


#6

Ah, so it is. Way easier than I thought. Tongue says the battery is fine, but I’ll get a new one (when there isn’t a bomb cyclone outside), and give that a shot, too.


#7

I found my Turn Touch wouldn’t pair with my Mac either. I took the battery out and let it sit for a few minutes without power. After putting the battery back in, it paired fine. I would suggest you try this before purchasing new batteries.


#8

Interesting idea! It shouldn’t have to sit for any longer than a tenth of a second, but “restarting” the remote may help.


#9

Thanks for the tip, @Tree_of_Dave. Unfortunately, still not having any success. Tried taking the old battery out (for various lengths of time). Just now tried a brand new battery. Then I took it out, and tried again a few more times. Not having any luck here.


#10

I have the exact same issue. I have replaced the shipped battery with a new one and just upgraded to the new version of the app. No change in my ability to pair the device.


#11

Try leaving the app open and the remote sitting in front of it for a day or two. All my attempts to restart/replace battery/etc never worked initially, but I went away for a couple days and came back to find that the app had found my Turn Touch!

I don’t know if it is to blame for this particular issue but unfortunately Bluetooth on both Mac and iOS can be incredibly flaky and there’s only so much apps and devices such as Turn Touch can do to work around it.


#12

While @njr’s technique may work, I only built that behavior into the Mac app, as the iOS app a) has better bluetooth, and b) won’t run in the background continuously scanning unpaired devices.

It’s tricky, because I’m sure there’s something more intelligent than what I’m already doing in the firmware to get it to connect, but I’m not sure what that is and I’ve paid a couple people quite a bit to help me get that perfected. There’s always more I can do but there’s diminishing returns right now, but that could change.

What will happen is once I’m all shipped in the next couple weeks, I’ll survey people and figure out who hasn’t gotten it to work but wants it to. And for all of those people I’ll ship out a replacement board that can be installed with just your hands.


#13

Thanks for the update, @samuelclay. In the meantime, I will give @njr’s technique a try. I’ll post again if it eventually works.


#14

The funny thing is (and I am not kidding here!) about 2 minutes after I posted this, the darned thing paired on its own without any help from me or clicking the button on the app. Now I just need to figure out how I want it to work with my home automation stuff!


#15

I can’t get it to pair with my Mac either, but it will pair with my iPhone. Is it possible that ti can’t be paired with two devices at once? I tried un-pairing with my iPhone, but it repaired automatically.


#16

Try turning off Bluetooth temporarily. You don’t have to unpair, but the phone can’t be trying to establish a connection.


#17

Hello! I’m having trouble getting my TurnTouch to pair with my Mac. It was running for a while — I then paired it to an iPad with the TurnTouch beta. I’ve since deleted the iPad TurnTouch beta.

On the Mac, I’m running High Sierra 10.13.5. I tried uninstalling & reinstalling the desktop TurnTouch software, and I have the iPad turned off. When I try to add a new remote on desktop, the app doesn’t see the remote. I’ve also tried replacing the battery. No joy. Any other thoughts on how to troubleshoot this?

Thank you.


#18

Hey, did you receive a new board? It should be working now. Let me know!


#19

I’m having the same issue: the remote will not pair with either the Mas OS app (macOS High Sierra v 10.13.6, Turntouch v 1.0.2) or the ipad app (both Turntouch version 2.0 on Testflight and the Turn Touch app on the app store)

Suggestions?


#20

If the remote won’t pair with either app it is most likely a dead battery. Try replacing the CR2032 and if that doesn’t work, I’m happy to send you a new board.