Option to connect to IFTTT in Mac app does nothing

I’m having the same problem described in this older post:

I just got my TT in the mail and have the app installed on my Mac. I successfully paired the TT and I can see the Connect to IFTTT button. I click the button and it changes to show “Edit IFTTT recipes” but it’s greyed out. I never get a prompt to log into IFTTT. I have to quit the app and re-open it to see the Connect button again, but the same thing happens, even after a reboot.

I got the TT specifically to work with IFTTT, so any help is greatly appreciated!

ETA: Got it working for my needs via webhooks, but still would love to get it connected to IFTTT.

Unfortunately I have two devices that does not works at all and their support is very lame so I’ve give up and stopped using them! Since than they both turned into a door stopper.

Try adding IFTTT as a batch action on to an existing button. I wonder if you’re in a flow that’s not connected to a single button. I just tried it end-to-end and it worked, so I have no idea why it’s not working for you, as the backend and the app should both be setup properly.

Hi, @samuelclay! Thanks for the response!

I’m not sure I follow what you mean by “batch action.” I clicked on a single button as far as I can tell. Here’s a video: https://www.screencast.com/t/cHLm3k9YiZ

I would guess that when I click “Connect to IFTTT,” it is trying to open some kind of authentication, and that’s the part that never opens. I’m not clear why the button immediately changes as if it’s already connected, but my guess would be that there’s an assumption the authentication window always works. Any thoughts? Is there an explanation somewhere of what’s supposed to happen at this step and how I can troubleshoot it not working? Is there a video of what the flow is supposed to look like?

That video was extremely helpful, thank you! Ok, try clicking on one fo the four actions in the IFTTT mode. You did it for the other modes (web, custom url) but not for IFTTT. Let me know if you’re able to connect to IFTTT. See this screenshot as an example:

That doesn’t do anything either, unfortunately: https://www.screencast.com/t/9fWoynUM9

I ended up trying this on my iPad and it works, so I’m guessing it’s just something about however the pop-up is supposed to open on the Mac. Anything I can dig into there? To my knowledge, I have no special setup on any of my browsers, and I gave TurnTouch Security > Privacy > Accessibility access as prompted.

I put out an update today that may address it. Go to the app and open Settings > About > Update. It’s v1.4.4.