Only volume responding on both iPad & iPhone

I just received my TT today and it is working well as a page turner in Forscore. When I tried to use it for other things the only function that works on iPad are the volume controls. I unpaired it and connected to my iPhone to see if Forscore was somehow interfering but it was the same. The phone vibrates indicating that it registered the button touch but it will not pause/play music, skip tracks or take a photo.
I tried toggling the Bluetooth switch and also removed the battery for a few minutes but neither had any effect.
Is it malfunctioning or is there a setting I need to change?
Otherwise it’s a beautiful little object and it works really well as a page turner.

I’m glad to hear it’s going well with forScore. As for the music controls, it should work but I’m not sure why it’s not working for your phone. Can you post a screenshot of the Turn Touch app where the controls should be set for music? I’m interested to see the device and settings.

Thanks for your prompt reply. I’ve been unwell so everything’s been on hold for a bit.
A bit of additional info: I can use the TT to cycle through the default programs and it responds. I’ve checked that it’s set to music before trying to use it. I’ve also deleted and reinstalled the app. I’ve tried it with the TT app in the foreground and the music app. I’ve tried disconnecting it from Forescore. Still the same as before. It reliably controls the volume and turns pages but cannot pause/play or skip tracks. All four buttons are physically working. I’m puzzled. Either I’m missing something obvious or something in the TT chip isn’t working properly.
Thanks for your help