Battery died/replaced, now cannot find WeMos

I had to replace my battery after only a few days. I think the battery got down to 45% the first day while I was setting it up. Luckily I had some extra batteries around, so I replaced it and reconnected the Turn Touch to my iOS app.

Prior to replacing the battery, I had set up some IFTTT and WeMo actions that worked pretty well.

However, after the new battery, my WeMo actions stopped executing properly. The phone indicated the button was pressed with a vibrate, and IFTTT actions still executed, but the WeMo actions weren’t executing. I decided to use the option to remove all wemos and re-add them. No wemos are discovered.

Additionally, I have a nest that I’ve only tried to discover after replacing the battery. It is not found. UPDATE: after reinstalling the app, I can log in to my nest account and this appears to work.

I’m making sure to use the 2.5ghz WiFi that the wemos are on, so I’m not sure what’s wrong. I also deleted and reinstalled the app, and it didn’t fix the issue. Please let me know how to proceed.

Thank you!

Wemo is a tricky app. I have a bunch of Wemos personally and what happens is that they change IPs. I introduced some code to automatically detect the new IPs but it isn’t battle tested yet. I did however add a setting cog to wemos to allow you to search for devices again.

Thanks for the response! A month ago, I assigned static IP addresses for all of my WeMos and many other devices in my router settings to try to improve connectivity.

I’ve been using the “Search for new devices” option in the Turn Touch app, and it unfortunately discovers none of them. I have 18 now.

I question whether this is a Turn Touch issue at all, though. This is coinciding with another problem that seemed to start at the same time: my Alexa devices won’t operate my WeMo devices when called by name anymore; Alexa says “[wemo device name] isn’t responding.” All of the apps (Alexa, WeMo, SmartThings) work to turn on/off the WeMos, and most Alexa device groups even work as well to turn on/off the same WeMo devices. That’s making this particularly puzzling to me.

Reddit’s Home Automation subreddit hasn’t been much help, either, unfortunately.

I’m not even sure which company to reach out to for support at this point.

Apparently it’s the router/firmware update. After swapping out that one for my older one, everything is working again.

And here I thought spending triple what I’d usually spend on a router would make reliability better. Silly me.

Thank you as always.

1 Like